Welcome to the Treehouse Community
Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.
Looking to learn something new?
Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.
Start your free trialHammad Shafiq
623 PointsThe code is correct but the compiler gives an error
I am getting the same error "Bummer! The naming convention ... " although I am typing the correct name
public class Spaceship{
public String mType;
public String getVariableName(){return mType;}
}
1 Answer
andren
28,558 PointsYou are interpreting the instructions a bit too literally, the naming convention for a getter is not literally the name "getVariableName" but the word "get" followed by the name of the variable you are getting minus the m that the variable name starts with.
So for a getter for the mType variable, the correct name would be getType, if you had a variable called mName the getter name would be getName and so on.
Hammad Shafiq
623 PointsHammad Shafiq
623 PointsThank you so much! Brilliant explanation. It did solve my problem.