Welcome to the Treehouse Community
Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.
Looking to learn something new?
Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.
Start your free trialVarun Singh
1,905 PointsHi i am getting the error " use return statement " but i think i am doing correct. what is the problem with this ? plese
public class ScrabblePlayer { // A String representing all of the tiles that this player has private String tiles;
public ScrabblePlayer() { tiles = "";
}
public String getTiles() { return tiles; }
public void addTile(char tile) { // TODO: Add the tile to tiles tiles += tile;
}
public boolean hasTile(char tile) { // TODO: Determine if user has the tile passed in boolean isTile = tiles.indexOf(tile) != -1; if(isTile) { tiles += tile; } else { return false; } return isTile; } }
public class ScrabblePlayer {
// A String representing all of the tiles that this player has
private String tiles;
public ScrabblePlayer() {
tiles = "";
}
public String getTiles() {
return tiles;
}
public void addTile(char tile) {
// TODO: Add the tile to tiles
tiles += tile;
}
public boolean hasTile(char tile) {
// TODO: Determine if user has the tile passed in
boolean isTile = tiles.indexOf(tile) != -1;
if(isTile)
{
tiles += tile;
}
else
{
return false;
}
return isTile;
}
}
1 Answer
Florian Tönjes
Full Stack JavaScript Techdegree Graduate 50,856 PointsHi Varun,
the challenge wants you to write the code more consise. Also, why do you add the tile in the hasTile method again? You already do this in the addTile() method. In the hasTile method you only want to check if the player has the tile. Your if statement would be correct, though.
You can shorten the code to this:
public boolean hasTile(char tile) {
return tiles.indexOf(tile) != -1;
}
Kind Regards, Florian